Ogłoszenie

Zwiń
No announcement yet.

Błąd botApi

Zwiń
X
 
  • Filtr
  • Czas
  • Pokaż
Wyczyść wszystko
new posts

    Błąd botApi

    Witam serdecznie! Otóż mam kilka zarejestrowanych botów, mam dane zabezpieczenie IP. Kod:

    $ip = $_SERVER['REMOTE_ADDR'];
    if(!preg_match('/^91\.197\.15\.[0-9]{1,3}$/', $ip))
    die('<center>=== ZABEZPIECZENIE SKRYPTU ===</center>');

    Gdy wyślę wiadomość do bota zwraca "<center>=== ZABEZPIECZENIE SKRYPTU ===</center>". Proszę o pomoc.

    Pozdrawiam Pezet.
    Ostatnio edytowany przez Pezet; [ARG:4 UNDEFINED].

    #2
    Dzień dobry,

    proszę zapoznać się z punktem 15 naszego FAQ:

    https://boty.gg.pl/faq/#15

    Komentarz


      #3
      Błąd nadal występuje.

      Witam. Po dodaniu

      if (!preg_match('/91\.((197\.1[2-5])|(214\.23[6-9]))\.[0-9]{1,3}/', $_SERVER['REMOTE_ADDR'])) die();

      od bota nie dostaje zadnej wiadomosci, a gdy dodam die('zabezpiecznie'); to daje tekst z die.

      Pozdrawiam Pezet.

      Komentarz


        #4
        Prosimy o kontakt za pomocą https://boty.gg.pl/kontakt/ W treści wiadomości proszę podać o jaki numer GG bota chodzi.

        Komentarz


          #5
          Po pierwsze nie pisz w kilku wątkach o tym samym,

          po drugie: spróbuj wyświetlić w bocie $_SERVER['REMOTE_ADDR'] i podaj co Ci wyszło
          GaduNews.pl
          Polska ekipa GTA:Online

          Komentarz


            #6
            Okazało się, że serwer na którym stoi bot użytkownika, ma na sztywno przypisany adres IP do zmiennej $_SERVER['REMOTE_ADDR'] przez co zawsze zwracany jest błąd.

            Komentarz

            Pracuję...
            X