Pokaż wyniki od 1 do 3 z 3

Wątek: Ramówka w bocie

  1. #1

    Ramówka w bocie

    Witam mam skrypt swojej ramówki i nie mogę dodać go do bota.

    To jest mój kod
    Kod:
    require_once('PushConnection.php');
    $M = new MessageBuilder();
    switch (file_get_contents("php://input")) {
    		include INFUSIONS."ramowka/infusion_db.php";
    
    // Check if locale file is available matching the current site locale setting.
    if (file_exists(INFUSIONS."ramowka/locale/".$settings['locale'].".php")) {
    	// Load the locale file matching the current site locale setting.
    	include INFUSIONS."ramowka/locale/".$settings['locale'].".php";
    } else {
    	// Load the infusion's default locale file.
    	include INFUSIONS."ramowka/locale/English.php";
    }
     case "Lolirock ramowka":
     $result = dbquery("SELECT * FROM ".DB_RAMOWKA." ORDER BY ramowka_id ASC");
    		if (dbrows($result)) {
    		 $M->addRawHtml("Ramówka na cały tydzień:<table cellpadding='0' cellspacing='0' width='50%' class='center'>";
    echo "<tr>
    <td class='tbl'>".$local['r015']."</td>
    <td class='tbl'>".$local['r016']."</td>	
    <td class='tbl'>".$local['r017']."a</td>	
    </tr>");
    while ($data = dbarray($result)) {
    	$M->addRawHtml("<tr>
    <td class='tbl'>".$data['ramowka_data']."</td>
    <td class='tbl'>".$data['ramowka_godziny']."</td>
    <td class='tbl'>".$data['ramowka_name']."</td>
    </tr>");
    
    
    }
    $M->addRawHtml("</table></br/>".$local['r021']."
    <br/>
    <center>Ogladaj na <a href='http://disneychannel.disney.pl/' target='_blank'><img src='".INFUSIONS."ramowka/images/disney_channel_logo.png' /></a></center>");
    }else{
    	
            break;
        default:
            $M->addRawHtml("<strong>Admin nie ustawił ramówki</strong><br/><br/>
    	<span style='color:red'><strong>Przerwa W emisji LoliRock</strong></span>");
    }
    }
    $P = new PushConnection(61886787, 'shryus@wp.eu', '021pawel021'); // autoryzacja
    $P->push($M);
    I wywala jak wpisuje Lolirock ramowka taki błąd
    Kod:
     Błąd - serwer nie zwrócił poprawnej wiadomości do wysłania (500 Internal Server Error).
    Proszę pomóżcie mi bo pierwszy raz to robię .

  2. #2
    myślę że powinieneś dać hasło do botapi a nie swoje

  3. #3
    Włącz wyświetlanie błędów dodając na początku
    Kod:
    ini_set('display_errors', 1); 
    error_reporting( E_ALL );
    Wtedy będzie Ci łatwiej znaleźć błąd

Podobne wątki

  1. Zmiana stylu czcionki w bocie.
    By Wazniak96 in forum Boty
    Odpowiedzi: 2
    Ostatni post / autor: 07.04.2015, 03:09

Uprawnienia umieszczania postów

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •