Pokaż wyniki od 1 do 6 z 6

Wątek: Błąd ;/

  1. #1
    RapStee
    Go

    Exclamation Błąd ;/

    Witam,
    Mam problem z pustą wiadomością.

    Kod php:
    $MB->addText("$nazwa rzuca kostką"FORMAT_BOLD_TEXT)->setRecipients($ALL);
    $P->push($MB);
    $MB->clear();
    sleep(3);
    $MB->addText("I Uzyskuje wynik $wynik !! "FORMAT_BOLD_TEXT)->setRecipients($ALL);
    $P->push($MB);
    $MB->clear(); 
    Jak dodam 3 Metody..

    Kod php:
    $MB->addText("$nazwa rzuca kostką"FORMAT_BOLD_TEXT)->setRecipients($ALL);
    $P->push($MB);
    $MB->clear();
    $MB->reply();
    sleep(3);
    $MB->addText("I Uzyskuje wynik $wynik !! "FORMAT_BOLD_TEXT)->setRecipients($ALL);
    $P->push($MB);
    $MB->clear();
    $MB->reply(); 
    Wyskakuje dziwne "S" pod wiadomością "I Uzyskuje wynik $wynik !!" :/ Nie wiem o co chodzi, ten błąd NIE wyskakuje na Komputerze. Na telefonach android itp. on wyskakuje. Wersja API 2.4

    Pozdrawiam RapStee

  2. #2
    Doświadczony GGadacz
    Dołączył
    27.03.2012
    Posty
    131
    Po clear nie dawaj reply, bo to zwraca pusty element do wywolujacego skrypt. Do telefonow mozesz wyslac addBBCode(ktos moze mnie potwierdzic jak to jest z wersja na telefony z java?) Na androidzie wszystko ladnie dziala, lecz po prostu nie koloruje/pogrubia etc. Tekstu
    Już niedługo...

  3. #3
    RapStee
    Go
    Popróbuje formatem tekstu addBBcode, może problem sie nie pojawi.

  4. #4
    RapStee
    Go
    Nadal jest puste pole po wiadomości... Wszystkiego próbowałem. (Kodowanie ustawione na UTF - 8 (Bez BOM))

  5. #5
    Doświadczony GGadacz
    Dołączył
    27.03.2012
    Posty
    131
    A spróbuj tego:
    Kod php:
    $MB->addBBCode("$nazwa rzuca kostką")->setRecipients($ALL);
    $P->push($MB); 
    $MB->clear();
    sleep(3); 
    $MB->addBBCode("I Uzyskuje wynik $wynik !! ")->setRecipients($ALL); 
    $P->push($MB);
    $MB->clear(); 
    U mnie to ładnie działa. Jeśli nadal nie będzie działać, odezwij się na PW, postaram się pomóc
    Już niedługo...

  6. #6
    RapStee
    Go
    ok, problem rozwiazany. dzieki za pomoc

Uprawnienia umieszczania postów

  • Nie możesz zakładać nowych tematów
  • Nie możesz pisać wiadomości
  • Nie możesz dodawać załączników
  • Nie możesz edytować swoich postów
  •